wiki:Install/MacOSX

Version 11 (modified by Brad Lanam, 18 months ago) (diff)

--

Installing BallroomDJ on Mac OS X

Install the Requisite Software

VLC
http://download.videolan.org/pub/videolan/vlc/2.1.5/macosx/

Currently, VLC 2.2.x does not work properly on Mac OS X. Install version 2.1.5.

Xcode

(Unfortunately, Mac OS X is not a very helpful or friendly platform to work with....)

Xcode is required to install the Xcode command line utilities, which are needed for MacPorts.

Install Xcode from the Mac App Store.

For versions of Xcode prior to 8.0:

Install the Xcode command line utilities:
sudo xcode-select --install

For versions of Xcode 8.0 and later:

Install Xcode command line utilities from the Apple developer website: http://developer.apple.com/download/more/

All versions of Xcode:

Accept the Xcode license:
sudo xcodebuild -license

MacPorts

http://www.macports.org/install.php

Other Utilities

Install the following using MacPorts:
sudo port install flac faad2 sox vorbis-tools imagemagick

Tcl/Tk

This step is only necessary for versions prior to version 3.0.6. Starting with version 3.0.6 and later, Tcl and Tk are included with BallroomDJ.

sudo port install tcl
sudo port install tk +quartz

Install BallroomDJ

Open the BallroomDJ .pkg file to install BallroomDJ.

Apologies

Installing BallroomDJ on the mac is wonky.

  • Sometimes it does an upgrade.
  • Sometimes it does a reinstall.
  • Sometimes it runs normally.

Why is a company with billions of cash not able to write a good installer.